Trucha Bug Restorer 1.14 by R2

      Trucha Bug Restorer 1.14 by R2

      Hier mein Trucha Bug Restorer MOD für 4.3

      Wie auch der normale TBR muss er mehrmals gestartet werden
      Kurze Anleitung:
      1. Ohne IOS Reload mit B weitermachen und nach dem Warnhinweis "Install IOS41" auswählen.
      2. IOS41 einstellen, mit A weitermachen und nach dem Warnhinweis "Downgrade IOS15" auswählen.
      3. IOS15 einstellen, mit A weitermachen und nach dem Warnhinweis "IOS36 menu" auswählen, jetzt wie gewohnt das IOS36 patchen.
      4. IOS36 einstellen, mit A weitermachen und nach dem Warnhinweis "Restore IOS15" auswählen.

      Wenn der HBC 1.0.7 inklusive IOS58 oder höher installiert ist nutzt man HW_AHBPROT, man geht folgendermasen vor:
      1. Ohne IOS Reload mit B weitermachen und nach dem Warnhinweis "IOS36 menu" auswählen, jetzt wie gewohnt das IOS36 patchen.

      Solltet ihr Fehlermeldungen oder Exceptions bekommen probiert bitte folgendes und erstattet Bericht:
      forum.wii-homebrew.com/index.p…e378214aae9a9385dd8fb5d95

      DOL+ELF+Sourcecode: im Anhang
      Files
      • tbrmod.rar

        (639.1 kB, downloaded 4,361 times, last: )
      • sip.zip

        (999.07 kB, downloaded 5,061 times, last: )



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      The post was edited 12 times, last by R2-D2199 ().

      Das tut auch der normale TBR 1.13.

      Dazu muss man aber IOS41 benutzen wie er schon schrieb.

      Halte das noch zu umständlich, der nächste Hackmii installer komtm eh bald, von daher kann man ruhig noch ein bisschen warten ;) (meine Meinung)



      Wii U 32 GB Premium



      N3DS Dual IPS a9lh


      Switch Smash Bros. Ultimate Edition @OFW


      PS 3 CECHC04 @CFW/OFW




      PS 4 Pro CUH 7116 1 TB



      Naja, der HackMii Installer installiert ja nur den HBC und patcht bestimmt kein IOS, damit man ein cIOS installieren kann, du kennst ja T_T.
      Für sowas war bisher immer der Trucha Bug Restorer bzw. Dop-Mii zuständig.

      Was ist eigentlich der Unterschied zwischen dieser Mod und dem Original TBR 1.13 wenn beide mit 4.3 funktionieren sollen?
      Der Unterschied ist folgender:

      Mit dem mod hat man die Möglichkeit direkt IOS41 vom NUS zu laden, mit dem Original hat man diese Möglichkeit nicht, da muss man das IOS 41 schon installiert haben, braucht also ein zweites Programm. (WadManager, oder MMM)
      Edit:
      ein kleines bischen zu langsam :(
      MfG
      m.tom59

      Firmware 4.3E
      Priiloader 0.30
      CIOS 249 rev.19 (Base 57)
      CIOS 250 rev.19 (Base 38)
      Hermes V5
      HBC 1.08
      WiiFlow USB Loader
      Bootmii in Boot2v4


      Firmware 4.3E
      Priiloader German Mod V0.5
      CIOS 249 rev.20 (Base 57)
      CIOS 250 rev.20 (Base 38)
      Hermes V5
      HBC 1.07
      WiiFlow USB Loader
      Bootmii in Boot2v4
      meine 2. Wii wird momentan ständig verändert

      Taurus wrote:

      Der Unterschied ist daher, dass die Mod gleich die IOS41 installieren tut, der normale hat die IOS41 Installation nicht.

      Stimmt, der normale installiert nur IOS36 im IOS36menu. Damit dürfte aber der normale TBR doch nicht mit 4.3 gehen.

      Edit: Ok, scheinbar hat der TBR 1.13 eine IOS-Auswahlfunktion die es bei den anderen TBR-Versionen nicht gibt ^^
      Da hasu recht =)

      Ich hab da au schon weitergedacht.

      ---> HBC auf 4.3 Virgin installieren

      Das meinte ich damit mit dass is bissle umständlich =)

      Aber nun gut, jmd ders kaum abwarten kann, kanns ja machen =)



      Wii U 32 GB Premium



      N3DS Dual IPS a9lh


      Switch Smash Bros. Ultimate Edition @OFW


      PS 3 CECHC04 @CFW/OFW




      PS 4 Pro CUH 7116 1 TB



      Der Trucha Bug Restorer 1.13 MOD 4.3 by R2 hat ein geringfügig geändertes Menu.
      Anstelle von "IOS 37 menu" hat der mod da "Install IOS41"

      MfG
      m.tom59

      Firmware 4.3E
      Priiloader 0.30
      CIOS 249 rev.19 (Base 57)
      CIOS 250 rev.19 (Base 38)
      Hermes V5
      HBC 1.08
      WiiFlow USB Loader
      Bootmii in Boot2v4


      Firmware 4.3E
      Priiloader German Mod V0.5
      CIOS 249 rev.20 (Base 57)
      CIOS 250 rev.20 (Base 38)
      Hermes V5
      HBC 1.07
      WiiFlow USB Loader
      Bootmii in Boot2v4
      meine 2. Wii wird momentan ständig verändert

      m.tom59 wrote:

      Der Trucha Bug Restorer 1.13 MOD 4.3 by R2 hat ein geringfügig geändertes Menu.
      Anstelle von "IOS 37 menu" hat der mod da "Install IOS41"

      MfG
      m.tom59


      Ja, ich hab einfach den Menüpunkt von IOS37 ersetzt, da der ja eh kaum gebraucht wird.


      So im Archiv sollte jetzt der Sourcecode, eine DOL und eine ELF Datei sein.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      The post was edited 1 time, last by R2-D2199 ().

      Ich hab das ganze mal mit der von WiiPower empfohlenen Version von libogc kompiliert, nun sollten weniger Code Dumps beim IOS Reload auftreten.
      Den Link im ersten Post habe ich aktualisiert.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      So, nach langer Zeit hab ich die TBR MOD mal aktualisiert:
      - Statt IOS36 v3607 wird jetzt v3351 verwendet, aber die Revisionsnummer wird auf 3607 geändert.
      Grund: Manche Programme, z.b. Hermes cIOS Installer haben Probleme mit dem gepatchten IOS36 v3607, mit v3351 klappt alles, ich vermute es liegt am Signaturchek im ES_AddTitleFinish, der ja bei v3607 neu ist.

      - Der TBR erkennt jetzt ob das IOS15 schon gedowngradet wurde und schreibt das wenn man versucht das IOS15 erneut zu downgraden.
      Grund: Wenn man das schon gedowngradete IOS15 nochmal versucht zu Downgraden kann es zu einem Error -1017 kommen, der verwirrt viele.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      Ich habe jetzt mal das Programm auf meiner FW4.3 getestet, aber ich brauchte 2 Versuche ^^

      1. Versuch
      Ich hatte schon IOS41 draufgehabt, dann mal Downgrade IOS15 versucht, kam aber fehlermeldung, also habe ich nochmal den 1. Schritt gemacht und versucht IOS41 neu zu installieren, kam auch Fehlermeldung ;(

      Ich habe im Syscheck kontrolliert und sah eine ganze andere IOS41 Version 3348, musss ich mir wahrscheinlich mal mit DopMii eingefangen haben, da ich sonst nicht weis wie ich die IOS41 drauf kam, also mit ATD gelöscht. 8o

      2. Versuch haben alle Schritte super geklappt, musste halt am Anfang IOS41 neu installieren, abe es war halt die IOS41v2835 ;)

      Jetzt habe ich erfolgreich IOS36 gepatched, super Programm :thumbup:

      Edit: Ich habe mal IOS202 von Hermes cIOS mit eingestellter IOS36 installiert, hat wunderbar geklappt :thumbup:

      The post was edited 1 time, last by Taurus ().

      Danke fürs Feedback, ich werde morgen eine Überprüfung für IOS41 einbauen, ob davon schon eine höhere Version installiert ist.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      So, wie versprochen die neue Version:

      - Statt IOS41 v2835 wird jetzt v3091 benutzt
      Grund: Mit v3091 gibt es wahrscheinlich weniger Code Dumps, da diese Version neuer ist, aber trotzdem noch mit dem TBR klappt.

      - Bevor das IOS41 installiert wird, wird geprüft ob die v3091 schon installiert ist, wenn sie schon installiert ist, meldet das der TBR un führt die Installation nicht nochmal aus. Wenn eine niedrigere Version installiert ist, wird die v3091 installiert. Wenn eine höhere Version installiert ist, meldet der Installer das und bricht ab.
      Grund: Wenn eine höhere Version installiert ist und man versucht eine ältere zu installieren kommt es zum ERROR -1035. Mit Versionen die höher sind als v3091 klappt das Downgrade des IOS15 nicht.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      Wow, schon wieder eine neue Version, werde sie in gegebener Zeit mal testen, wenn ich wiedermal meine FW4.3 aktualisiere, da wird dann wieder IOS36 aktualisiert und Trucha entfernt.

      R2-D2199 wrote:

      Grund: Wenn eine höhere Version installiert ist und man versucht eine ältere zu installieren kommt es zum ERROR -1035. Mit Versionen die höher sind als v3091 klappt das Downgrade des IOS15 nicht.
      Leider habe ich diese Fehlermeldung erfahren, da ich eine neuere Version von IOS41 hatte, aber es hatte dann schon geklappt mit der IOS41v2835 und alle Schritte. Aber werde trotzdem auch mal die Version probieren. ^^
      Da ich gestern mal den TBR verwendet habe und IOS36 gepatched habe.

      Ich habe jetzt mal meine FW4.3 aktualisiert, da ja IOSe verändert wurde, hat auch mit Erfolg geklappt. Ich dachte immer bei FW4.3 wird auch Trucha deaktiviert bei IOSe, aber die IOS36 blieb unberührt. Die IOS36 ist noch Trucha aktiviert. Oder liegt es auch daran, dass es schon die neueste Version ist und trotzdem nicht wieder ungepatched installiert wird bei FW4.3 Aktualisierung. ^^

      Taurus wrote:

      Da ich gestern mal den TBR verwendet habe und IOS36 gepatched habe.

      Ich habe jetzt mal meine FW4.3 aktualisiert, da ja IOSe verändert wurde, hat auch mit Erfolg geklappt. Ich dachte immer bei FW4.3 wird auch Trucha deaktiviert bei IOSe, aber die IOS36 blieb unberührt. Die IOS36 ist noch Trucha aktiviert. Oder liegt es auch daran, dass es schon die neueste Version ist und trotzdem nicht wieder ungepatched installiert wird bei FW4.3 Aktualisierung. ^^


      Dafür muss man zuerst mal gucken was bei einem Update von Nintendo passiert:
      Schritt 1: Die Wii guckt auf dem Nintendo Server nach welche Systemdaten in welcher Version vorliegen.
      Schritt 2: Die Wii überprüft ob alle installierten Systemdaten in der selben Version vorliegen
      Schritt 3: Die Wii lädt alle Systemdaten die nicht installiert sind oder in einer niedrigeren Version installiert sind runter und installiert sie.

      So, das aktuelle IOS36 ist v3607, das wird auch vom offiziellen TBR gepatcht installiert.
      v3607 hat aber durch den Fix in der Funktion ES_AddTitleFinish Probleme mit allen Apps die patchmii_core verwenden (z.b. Hermes cIOS Installer und WiiSCU).
      Um das zu vermeiden benutzt diese Modifikation IOS36 v3351, damit das aber nicht von Nintendo überschrieben wird ändert der TBR die Versionsnummer auf 3607.
      Also denkt die Wii sie hätte IOS36 v3607 installiert, hat aber in wirklichkeit IOS36 v3351, da es die Versionsnummer 3607 hat.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      juweger wrote:

      Dann kann man jetzt wie mit WiInstall die IOS downgraden, ohne cIOs installiert zu haben ?
      Oder werden die neun IOS benutzt (z.B. das IOS 36 v3608).
      Das Donwngraden ist gar nicht mehr nötig, man kann direkt das gepatchte IOS36 installieren.
      Es wird weiterhin die v3351 benutzt, allerdings wird die Versionsnummer auf 3608 geändert damit es nicht überschrieben wird.

      Ark wrote:

      R2-D2199 wrote:

      So ich hab den TBR mal HW_AHBPROT kompatibel gemacht, er klappt jetzt auf mit dem "neuen" 4.3 Update.

      Heißt das er kann jetzt das IOS36 sofort patchen ohne Downgrade von IOS15 und ohne koreanische IOS?
      Genau.



      FW: 4.1E (v65535)
      Launch Day Wii
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader


      FW: 4.1E (v65535)
      IOS249[56] d2x-v8
      Hermes cIOS rev5.2
      cfg USB Loader






      AMD Fusion E-350 @ 1,6 GHz
      2 GB DDR3 RAM
      4 TB HDD

      The post was edited 1 time, last by R2-D2199 ().

      R2-D2199 wrote:

      juweger wrote:

      Dann kann man jetzt wie mit WiInstall die IOS downgraden, ohne cIOs installiert zu haben ?
      Oder werden die neun IOS benutzt (z.B. das IOS 36 v3608).
      Das Donwngraden ist gar nicht mehr möglich, man kann direkt das gepatchte IOS36 installieren.
      Es wird weiterhin die v3351 benutzt, allerdings wird die Versionsnummer auf 3608 geändert damit es nicht überschrieben wird.

      Ark wrote:

      R2-D2199 wrote:

      So ich hab den TBR mal HW_AHBPROT kompatibel gemacht, er klappt jetzt auf mit dem "neuen" 4.3 Update.

      Heißt das er kann jetzt das IOS36 sofort patchen ohne Downgrade von IOS15 und ohne koreanische IOS?
      Genau.

      Nur mit Umwegen über Wiinstall ging die Vorversion.

      Ich werde mal deine neue Version testen, aber vorher muss ich wieder mein systemupdaten, um IOS41, IOS15 und IOS36 auf den neusten Stand zu bringen. ^^