Pinned Required Wiimmfi Patcher update for Mario Kart Wii

      New

      @Leseratte i thought the mac wiimmfi patcher worked when i ran it yesterday but turns out the wiimmfi-images folder with the iso support to be in it wasn't there (i didn't check if the wiimmfi-images folder wasn't in the wiimmfi patcher v6 folder i just turned my mac off presuming it worked) so i ran the whole command again on terminal and it displays this which i attached via screenshot (btw the red scribbles is covering my mac user name) what should i do? at least i now know how to get the command to work so i thank you for that :)
      Images
      • Screen Shot 2020-07-07 at 19.47.22.png

        133.33 kB, 1,131×738, viewed 12 times
      :43px-GCNController.svg: :23px-SDGecko.svg: :8px-Wiimote1.svg: :iwata:

      New

      Can confirm this happens on my Mac too (using zsh on Big Sur):

      Source Code

      1. ❯ ./patch-wiimmfi.sh
      2. Setup...
      3. ./bin/setup.sh: line 343: ${tool^^}=\"$bin\": bad substitution
      4. ./bin/setup.sh: line 343: ${tool^^}=\"$bin\": bad substitution
      5. ./bin/setup.sh: line 352: : command not found
      6. ./bin/setup.sh: line 353: : command not found
      7. ##----------------------------------------------------------------------------
      8. ## PATCHER = Mario Kart Wii: Wiimmfi patcher v6
      9. ## HOST = mac
      10. ## WIT =
      11. ## WSZST =
      12. ## WIT-VER =
      13. ## WSZST-VER =
      14. ##----------------------------------------------------------------------------
      15. ./bin/setup.sh: ./patch-wiimmfi.sh: line 8: syntax error near unexpected token `&'
      16. ./bin/setup.sh: ./patch-wiimmfi.sh: line 8: ` patch_job wiimmfi "$src" |& tee "_log/${src##*/}.log"'
      Display All

      it's probably some syntax differences between Linux and Mac scripts tbh
      I currently host the DLS1, GAMESTATS, and Peerchat server for Wiimmfi. if you have any issues with leaderboards (excluding MKW!), Mystery Gifts or other in-game downloadables, or Pokémon Wi-Fi Plaza, I can try to help! :P

      New

      Maybe the script uses some newer bash features that the Mac version doesn't have?

      What's the output of bash --version, and can you use a newer version of bash?

      DevkitPro Archiv (alte Versionen / old versions): wii.leseratte10.de/devkitPro/
      Want to donate for Wiimmfi and Wii-Homebrew.com? Patreon / PayPal

      Dieser Beitrag wurde bereits 0 mal editiert, zuletzt von Leseratte ()

      New

      Hey Leseratte,

      I waited 7 days after doing what I thought would fix my problem, which is to run the patcher using this video. It still didn't work.

      So, after having to wait the 7 days twice now (14 days), I'm still having problems, with the error code 23934 show up. Again, I'm on the classic wii, I'm not on Dolphin.

      I'm getting frustrated because I don't know what else to do. And I'm not entirely sure how to get in touch with Mr Bean.

      New

      Interesting. I've only seen that error happen on a real Wii once, where the system files were completely fucked up ...

      - Can you access the Wii Shop Channel without problems?
      - Do you have Bootmii on your Wii / do you have a NAND backup? If so, can you send me the keys.bin file in a private message?
      - If you have Homebrew on your Wii, do you remember what tutorial you used? Maybe there's something weird that you installed ...

      DevkitPro Archiv (alte Versionen / old versions): wii.leseratte10.de/devkitPro/
      Want to donate for Wiimmfi and Wii-Homebrew.com? Patreon / PayPal

      Dieser Beitrag wurde bereits 0 mal editiert, zuletzt von Leseratte ()

      New

      - When I try to access the Wii Shop Channel, I get "Error Code 204904; An error has occurred that cannot be resolved at this time. Please try again later."
      - I do not have Bootmii/NAND backup, if I need it, would you send me a tutorial on how to get it?
      - I do not have Homebrew, I used this tutorial to download CTGP, which did not require Homebrew installation. After I noticed Wiimmfi didn't work because I was getting error code 23934, I eventually used the tutorial I sent in the last message to run a patcher. This gave me the same error code. If I'm supposed to have Homebrew, would you send me a tutorial on how to get it?

      New

      Okay, if your Wii hasn't been homebrewed in the past then Bootmii probably won't be helpful.
      Did you ever use the Wii Shop in the past, do you remember if it ever worked?

      The errors in the Wiimmfi logs for your console seem to indicate some kind of software or hardware defect, but that would usually result in a different error code in the Wii Shop Channel ...

      When you switch the DNS back to automatic (away from the Wiimmfi DNS) do you get the same error for the Shop?

      DevkitPro Archiv (alte Versionen / old versions): wii.leseratte10.de/devkitPro/
      Want to donate for Wiimmfi and Wii-Homebrew.com? Patreon / PayPal

      Dieser Beitrag wurde bereits 0 mal editiert, zuletzt von Leseratte ()